vue3 + ts + vite 开发打包后报错

vue3 + ts + vite 开发打包后报错require is not defined

麻烦您提供一下,报错信息,以及使用的 vue-ui-components 的版本号

“vue”: “^3.2.25”,
@authing/sso”: “^2.1.17-alpha.5”,
“authing-js-sdk”: “^4.23.23”,

打包后提示require is not defined

我单独注释掉这两个库就不会报错

typescript 中需要使用 import 语法,

require 是 cjs 的语法。

直接将原有 require 语句需改成 import 即可。

比如

const { a } = require('b')
// 改为
import { a } from 'b'

那我现在要改你们的npm包嘛

我们会尽快升级 sso 包。给您造成不便非常抱歉

您好,vite 在 dev 环境下默认有对 commonjs 的转换支持,如果是 build 后报错:require is not defined,可以参考这个帖子解决:尝试在 nuxt3 中使用失败