java使用managementClient.users().update 修改密码时返回2016

java使用managementClient.users().update 修改密码时返回2016


麻烦您提供一下正在使用的 java sdk 的版本号哈。

4.3.29版本

您好,这个问题在旧的版本会存在。
在 SDK [4.3.35] 版本修复了这个问题,建议您升级到最新版本 [4.3.44] 再尝试。

1 Like

4.3.33以上版本都会报错,使用不了,是有新的调用方式吗

调用方式没有改变,可以提供报错信息吗?我们排查一下

显示无法解析,找不到这个类。
从源码里点进去也无法反编译看到内容

切换到4.3.33及以下版本的时候就是正常的

我们经过测试是没有问题。
您可以发一下您的本地运行环境和项目环境及版本,我们尝试复现问题。
或者您可以尝试清理依赖包重新引入。

已解决,经过测试是我IDEA的Kotlin版本过低,升级后已成功解决问题。感谢您的解答!(建议文档里标注需要的Kotlin版本)
image

收到,感谢您的反馈!我们加入到优化计划里。